PHP is one of the most commonly used general-purpose scripting languages. It is rather popular because it is free software, which can be used to develop responsive websites like community portals, e-stores or e-learning websites rather than static HTML-based sites. A PHP module should be enabled on the server where a PHP-driven site is hosted so that its code can be ‘decoded’. Because there aren’t any license fees for this sort of module and the language provides incalculable possibilities for the apps that you build, there are 100s of millions of PHP-powered websites. Additionally, there’re plenty of PHP scripts, which you can use for your sites without needing to possess any programming know-how. Considering the fact that there are several versions of PHP, you must check if the exact same version that you used while setting up your site is enabled on the web server as well.
PHP 4 and PHP 5 Support in Shared Hosting
We have made a decision not to restrict our present and future customers from picking what PHP version will be used by their websites, which implies that if you order a shared hosting plan from our company, you will be able to select between versions 4, 5.2, 5.3, 5.4 and 5.5, not only for the hosting account as a whole, but also for each domain that you host. This can be done with only one single mouse click from our in-house developed Hepsia Control Panel via which all hosting accounts are administered, so you will not have to possess any technical or programming experience. You’ll be able to manage sites built with both new and old scripts without any hassle, so if you would like to abandon your present web hosting company and switch over to us, you can be certain that all the websites that you have built through the years will continue to work flawlessly.
PHP 4 and PHP 5 Support in Semi-dedicated Hosting
Even if your websites were built with an older version of PHP, you’ll be able to host them in a semi-dedicated server account from us, as we support multiple versions running simultaneously on our semi-dedicated servers and each one of them can be activated for your account with no more than a click of the mouse through our custom-built Hepsia Control Panel. Apart from the most recent PHP 5.5 and PHP 5.4, we also offer 5.3, 5.2 and the older PHP 4. The latter has already been dropped by the majority of hosting providers, but we reckon that you shouldn’t be forced to modify a site that took years to build, since older scripting language syntax does not necessarily equal security breaches. Just the opposite, a properly maintained website using PHP 4 can be more reliable than an unmaintained one using PHP 5. For your convenience, we will also provide you with the possibility to specify a different version for each website within the account.